RAD Studio 10.4.1 is now available! Learn more. Looking for discounts? Visit our Special Offers page!
Delphi

Error ‘Could Not Load SSL Library’ when using Indy SSL components

Author: Embarcadero USA

Problem:

When using the Indy SSL components, an error ‘Could Not Load SSL Library’ is raised.

Answer:

This error is raised because you must have OpenSSL installed on your machine in order to use the IndySSL components. At runtime, Indy attempts to load libeay32.dll and ssleay32.dll. Due to restrictions on exporting SSL technology, these .dll’s are not distributed along with Indy. Please review Indy’s SSL site for information on where you can obtain the OpenSSL .dll’s.

http://www.indyproject.org/ssl.html

Article originally contributed by Angel Martinez


Reduce development time and get to market faster with RAD Studio, Delphi, or C++Builder.
Design. Code. Compile. Deploy.
Start Free Trial   Learn More About Upgrading

Related posts
C++

What's New in the GetIt Package Manager - June 2020

C++

RAD Studio 10.4 Now Available, Learn More

C++NewsRAD Studio

Open for Business with 10.4! - May 2020 GM Update

C++DelphiNews

Embarcadero Open Source Project Sponsorship

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

IN THE ARTICLES